saab92x.com - Over 10% of all 9-2x owners registered

Saab92x.com is dedicated to the discussion of the Saab 9-2x sport wagon, based on the Subaru WRX.
Please register or login to post.

Welcome to Saab92x.com!
Saab92X.com is the premier Saab92X forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!

#1 2017-03-12 17:42:22

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Hazards not working

Hey guys....the hazards in my car have never worked...not sure how i got a sticker last year but either way i am trying to fix this issue for my march safety inspection

- turn signals work
- replacement used switch doesn't make a difference
-no blow fuses

Any ideas?..

Also...Ive noticed that under the on the drivers side under the dash there's a green connector (it's almost neon green) that's disconnected ...looks like its for 2 wires..and the connector is almost shaped like a t...is this related?...I don't want to connect something without knowing


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

Remove Advertisements Advertisement

Saab92X.com

Offline

 

#2 2017-03-12 20:02:49

snowphun
Member
From: Central CT
Registered: 2005-11-09
User Number: 890
Posts: 250

Re: Hazards not working

jixaw wrote:

Also...Ive noticed that under the on the drivers side under the dash there's a green connector (it's almost neon green) that's disconnected ...looks like its for 2 wires..and the connector is almost shaped like a t...is this related?...I don't want to connect something without knowing

That connector gets shorted when you want to flash the ECU.

No idea on the hazard switch.

Offline

 

#3 2017-03-12 21:28:39

countriccati
Member
From: Boston
Registered: 2015-02-18
User Number: 28345
Posts: 191

Re: Hazards not working

Not sure about linears but on my Aero the turn signal and hazards are different fuses under the hood, so that would be my best guess if replacement switch doesn't make a difference. On my car they are two separate 15 AMP fuses, the hazards have their own dedicated fuse. Look in your owners manual to figure out exactly which fuse is for your hazards and try swapping in one of the spare replacements you should have in the fuse box, or getting one (maybe along with a tester) at autozone (or equivalent).


me and my aero

Offline

 

#4 2017-03-12 22:57:17

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Re: Hazards not working

Thanks for the tip...i located that fuse...it looked fine but i swapped it anyway...still no hazards...horn works and its on that fuse  confused ....i hate looking for bad wires


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

#5 2017-03-13 10:18:25

countriccati
Member
From: Boston
Registered: 2015-02-18
User Number: 28345
Posts: 191

Re: Hazards not working

Oof, that's too bad. Just in case you weren't aware the manual with wiring diagrams is available on here: http://saab92x.com/manuals/2005shopmanu … %20Sys.pdf
Still going to be quite an undertaking to figure out exactly what's wrong but at least it's somewhere to start. Having a wire tester will help too.
As an aside (and apropos your other thread) you might try to find another inspection location, some are nicer than others.


me and my aero

Offline

 

#6 2017-03-16 12:46:39

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Re: Hazards not working

thanks for the diagram...its actually not to hard to read...

question for all...does your hazard switch light up?..mine does not...im also thinking of pulling the switch and bridging wires to see if i can get anything.....


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

#7 2017-03-16 12:49:36

snowphun
Member
From: Central CT
Registered: 2005-11-09
User Number: 890
Posts: 250

Re: Hazards not working

jixaw wrote:

question for all...does your hazard switch light up?.

This is a Subaru, no luxuries like that in here.  tongue

Offline

 

#8 2017-03-20 12:52:43

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Re: Hazards not working

attempted to replace a burnt out side marker bulb with a Sylvania 2825 from my local advanced auto.....the old bulb was burnt out......swapped to a new bulb...no light...swapped to the second new one....no light....

theres no correlation between sidemarker and hazards is there?...im hoping for something in common


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

#9 2017-03-20 15:15:38

krazykarguy
Worst ninja editor, ever.
Supporter
From: South Carolina
Registered: 2007-04-06
User Number: 1944
Posts: 8171

Re: Hazards not working

The sidemarkers are not part of the signal circuit.

OK, here's an interesting test - try your turn signals and see what happens when you press the hazard button. Try the opposite - press in the hazard button, then try the turn signals. Do they stop blinking/lighting?

If so, I would guess your problem is with the flasher relay unit in the car, not the switch or the wiring. Don't ask me where it's located... confused


2005 Aero 5MT
2014 Ford Mustang GT Premium 6MT - Sterling Gray Metallic

Offline

 

#10 2017-03-20 15:52:01

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Re: Hazards not working

I actually have already done this......

1 - turn signal on (left/right) - signals work
2 - press hazard switch while signal on - signals stop (does this for left or right)

1 - press hazards - nothing
2 - turn signal on (left or right) - nothing
3 - press hazards off - signal (left or right) flashes like it should

does that sound like the flasher relay?

anyone know where this is?...i have a linear if that makes a diff


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

#11 2017-04-13 20:51:01

elislider
accept no substitutes
Registered: 2014-11-30
User Number: 25881
Posts: 386

Re: Hazards not working

turn your blinker on and follow the sound of the clicking.... smile

Offline

 

#12 2017-04-14 10:39:44

jixaw
Member
From: Cambridge, MA
Registered: 2016-02-22
User Number: 35856
Posts: 82

Re: Hazards not working

ugh i was waiting for someone to say that lol....i havent even bothered to complete this.....got my safety inspection


2005 Saab 9-2x Linear - Auto - Deep Mica Blue - Cold Weather Package - - Mods: Aero Rear Sway Bar, Perrin FSB, Whiteline QR RSB, Tsudo UEL, Custom catback with Magnaflow, 17" ASAs w/Dunlop Direzzas (summer), 16" OEM alloys w/studded Nokian hakka 7's (winter), 35% tint sides/rear

Offline

 

Board footer

Site problems, bugs, or questions? Contact Administrator
All content copyright Saab92x.com 2005-2010
SAAB and the SAAB logos are trademarks of Saab Cars USA, Inc.