saab92x.com - Over 10% of all 9-2x owners registered

Saab92x.com is dedicated to the discussion of the Saab 9-2x sport wagon, based on the Subaru WRX.
Please register or login to post.

Welcome to Saab92x.com!
Saab92X.com is the premier Saab92X forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!

#1 2016-12-08 08:31:08

tonymitss5
Member
From: Rochester, NY
Registered: 2011-02-22
User Number: 5232
Posts: 59

multiple CEL codes after cat and rear O2 sensor replacement

I have a 2005 Linear. 181k miles. NY federal emissions.

Have had P0420 code on for a long time, converter and midpipe rotted and broke. Yesterday I had a walker 54573 cat, walker midpipe, and walker muffler installed. Rear O2 sensor threads were in poor shape so a new denso was installed...

So the walker 54573 cat has three bungs. On my car the shop installed the upstream right afte the DP flange. The downstream is in the second bung. And the third bung (right before the midpipe) has a screw plugging the hole.

Is this where the downstream should be?

The wire for the downstream O2 will definitely not reach the third bung.


The car has The following codes:

P2097
P0131
P0420
P0037

Questions:

Is the rear O2 in the right bung, 2nd instead of 3rd?

Does it sound like my front O2 sensor is bad? I really don't see how the harness would be damaged.

Thanks.

Tony

Last edited by tonymitss5 (2016-12-11 17:49:50)


2005 Saab 9-2x Linear - 5MT - Satin Gray - Cold Weather - OEM Fog Lamps - OEM Bug Deflector -
2007 BMW 335i Sedan - 6MT - Crimson Red - ZSP - ZPP - ZCW - Active Steering - Comfort Access - SOLD -
2011 Honda Pilot EX-L 4WD - NAVI - Crystal Black Pearl - OEM Side Steps - OEM All Weather Mats -
2012 Acura TSX SE - 6MT - Bellanova White - ETA 12/21-25/2011!!!!

Offline

 

Remove Advertisements Advertisement

Saab92X.com

Offline

 

#2 2016-12-12 14:02:36

elislider
accept no substitutes
Registered: 2014-11-30
User Number: 25881
Posts: 339

Re: multiple CEL codes after cat and rear O2 sensor replacement

Did you reset the ECU after doing all this work?
are you sure the right O2 sensors were used? you need the OEM ones or OEM equivalent based on a reference like this:
http://share.subiefiles.com/subiefiles/ … erence.pdf

Offline

 

#3 2016-12-13 09:03:39

tonymitss5
Member
From: Rochester, NY
Registered: 2011-02-22
User Number: 5232
Posts: 59

Re: multiple CEL codes after cat and rear O2 sensor replacement

elislider wrote:

Did you reset the ECU after doing all this work?
are you sure the right O2 sensors were used? you need the OEM ones or OEM equivalent based on a reference like this:
http://share.subiefiles.com/subiefiles/ … erence.pdf

I unplugged the battery. Let it set for 15. Let it idle for 15 minutes to reset the throttle mapping. Drive maybe 2000ft up the road and CEL back on.

Yes I used the OEM denso downstream.

The upstream is an OEM denso, it is 3 years old.

Fuel economy is terrible lately though.


2005 Saab 9-2x Linear - 5MT - Satin Gray - Cold Weather - OEM Fog Lamps - OEM Bug Deflector -
2007 BMW 335i Sedan - 6MT - Crimson Red - ZSP - ZPP - ZCW - Active Steering - Comfort Access - SOLD -
2011 Honda Pilot EX-L 4WD - NAVI - Crystal Black Pearl - OEM Side Steps - OEM All Weather Mats -
2012 Acura TSX SE - 6MT - Bellanova White - ETA 12/21-25/2011!!!!

Offline

 

#4 2016-12-16 14:26:19

elislider
accept no substitutes
Registered: 2014-11-30
User Number: 25881
Posts: 339

Re: multiple CEL codes after cat and rear O2 sensor replacement

I can't remember if those are MAF based, but if so, clean the maf.
Maybe even go so far as to replace the knock sensor, especially if it has any cracks.

Offline

 

#5 2017-01-10 17:33:11

tonymitss5
Member
From: Rochester, NY
Registered: 2011-02-22
User Number: 5232
Posts: 59

Re: multiple CEL codes after cat and rear O2 sensor replacement

Ending up having to replace the front O2 sensor. Car was fine for 600 miles. Passed emissions inspection. Then last night the car seemed to be misfiring at idle speed. Today driving home from work the CEL came on. P0302 code.

Plugs are 3k miles old. Wires are 40k miles old. Cool pack has been replaced. Injectors are original 182k miles.

Any thoughts?


2005 Saab 9-2x Linear - 5MT - Satin Gray - Cold Weather - OEM Fog Lamps - OEM Bug Deflector -
2007 BMW 335i Sedan - 6MT - Crimson Red - ZSP - ZPP - ZCW - Active Steering - Comfort Access - SOLD -
2011 Honda Pilot EX-L 4WD - NAVI - Crystal Black Pearl - OEM Side Steps - OEM All Weather Mats -
2012 Acura TSX SE - 6MT - Bellanova White - ETA 12/21-25/2011!!!!

Offline

 

#6 2017-01-15 20:28:53

elislider
accept no substitutes
Registered: 2014-11-30
User Number: 25881
Posts: 339

Re: multiple CEL codes after cat and rear O2 sensor replacement

replace the knock sensor. also probably worth replacing the coil wires or at least inspection both ends to make sure they have a clean solid connection that grips tightly. might also be worth taking out a plug to see if any are worn/fouled.

a faulty front O2 sensor will cause the car to run wildly inefficiently, and could do all sorts of other mildly annoying damage (like running way too rich or lean and causing plugs to wear out)

Offline

 

Board footer

Site problems, bugs, or questions? Contact Administrator
All content copyright Saab92x.com 2005-2010
SAAB and the SAAB logos are trademarks of Saab Cars USA, Inc.